import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#[NCRLTBUIOSFAGKP]\\{(\\d+):(#[NCRLTBUIOSFAGKP]\\{\\d+(?:;F)?\\}|S|C|R)(:\\d+)?\\}";
final String string = "Ejemplos Válidos:\n\n"
+ "Ejemplo 1: #A{4:#S{520}:1}\n"
+ "Ejemplo 2: #A{4:#S{520;F}:2}\n"
+ "Ejemplo 3: #A{4:#S{520}:5}\n"
+ "Ejemplo 4: '#A{4:#S{520;F}:8}'!=''\n"
+ "Ejemplo 5: '#A{4:#S{520}:7}'!=''\n"
+ "Ejemplo 6: '#A{4:#S{520;F}:4}'=='A'\n\n\n"
+ "Ejemplos Inválidos:\n\n"
+ "Ejemplo 1: #A{354:#S{500;F}:1:F}\n"
+ "Ejemplo 2: #A{354;#S{500;F};1}\n"
+ "Ejemplo 3: #S{500";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}