package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+\d{1}(?:.\d{3}.)\d{3}-\d{4}`)
var str = `+7(333)333-4444`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}