$re = '/^0x[a-fA-F0-9]{1,40}$/m';
$str = '0xc1e5017fbc68aa3e56aa580708de9aa123d62d18!
0xc1e5017fbc68aa3e56aa580708de9aa123d62d18';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);