re = /^0x[a-fA-F0-9]{1,40}$/m
str = '0xc1e5017fbc68aa3e56aa580708de9aa123d62d18!
0xc1e5017fbc68aa3e56aa580708de9aa123d62d18'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end