// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0x[a-fA-F0-9]{1,40}$").unwrap();
let string = "0xc1e5017fbc68aa3e56aa580708de9aa123d62d18!
0xc1e5017fbc68aa3e56aa580708de9aa123d62d18";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}