#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)((?:\G(?!\A)|START_TAG)(?:(?!START_TAG|FOO).)*?)FOO(?=.*END_TAG)"
Local $sString = "Text multiline, bla bla bla **FOO** text text text *START_TAG* text text text text **FOO** a lot of texts" & @CRLF & _
"**FOO** more text" & @CRLF & _
"*END_TAG*"
Local $sSubst = "$1<Replaced>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)