$re = '/((?:\G(?!\A)|START_TAG)(?:(?!START_TAG|FOO).)*?)FOO(?=.*END_TAG)/s';
$str = 'Text multiline, bla bla bla **FOO** text text text *START_TAG* text text text text **FOO** a lot of texts
**FOO** more text
*END_TAG*';
$subst = "$1<Replaced>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;