#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:https?:)?(?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n]+)"
Local $sString = "https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22" & @CRLF & _
"http://mplay.google.co.in/sadfask/asdkfals?dk=10" & @CRLF & _
"http://lplay.google.co.in/sadfask/asdkfals?dk=10" & @CRLF & _
"http://play.google.co.in/sadfask/asdkfals?dk=10" & @CRLF & _
"http://tplay.google.co.in/sadfask/asdkfals?dk=10" & @CRLF & _
"http://www.google.co.in/sadfask/asdkfals?dk=10" & @CRLF & _
"www.google.co.in/sadfask/asdkfals?dk=10" & @CRLF & _
"http://user:pass@google.com/?a=b#asdd" & @CRLF & _
"//mplay.google.co.in"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")