#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?=.*?[0-9]) #содержит хотябы одну цифру" & @CRLF & _
"(?=.*?[A-Z]) #содержит хотябы одну латинскую прописную букву" & @CRLF & _
"(?=.*?[a-z]) #содержит хотябы одну латинскую строчную букву" & @CRLF & _
"(?=.*?[^0-9A-Za-z]) #содержит хотябы один знак пунктуации: !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~" & @CRLF & _
"#не имеют 6 и более подряд совпадающих символов типа "zzzzzz", "000000"" & @CRLF & _
"(?!.*?(.)\1{5,})" & @CRLF & _
"#не имеет "плохих" последовательностей типа "123456", "abcdef", "qwerty"" & @CRLF & _
"(?!.*?123456)" & @CRLF & _
"(?!.*?(?i:qwerty|asdfgh|zxcvbn|qazwsx|abcdef))" & @CRLF & _
"#допускаются только цифры, английские буквы и знаки пунктуации" & @CRLF & _
"[\x20-\x7e]{8,72} #ограничения по кол-ву символов" & @CRLF & _
"$"
Local $sString = "_012345_zZ" & @CRLF & _
"_123456_zZ" & @CRLF & _
"_00000_zZ" & @CRLF & _
"_000000_zZ" & @CRLF & _
"^@},hJu>[4Bo7TGX" & @CRLF & _
"_}24I:9t58Tu?m@e" & @CRLF & _
"|YlzEc|1" & @CRLF & _
"#m_4xF%t"Bu5jeb$" & @CRLF & _
"12345678aA@ " & @CRLF & _
"12345678 aA@" & @CRLF & _
" 12345678aA@" & @CRLF & _
"123Qwerty45678aA" & @CRLF & _
"^@},^@},^@}," & @CRLF & _
"AbCdEfGhIi" & @CRLF & _
"abcdefgh123" & @CRLF & _
"ABCDEFGH1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")