$re = '/(SKU\d{4})\h(.+)\h(.+)/u';
$str = 'SKU1234 Widget 1 $12.95';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);