using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\.)((^|\.)([1-9]?\d|1\d\d|2(5[0-5]|[0-4]\d))){4}$";
string input = @"115.42.150.37
192.168.0.1
110.234.52.124
01.01.01.01
1.1.1.01
123123123213
210.110
255
y.y.y.y
255.0.0.y
666.10.10.20
4444.11.11.11
33.3333.33.3
365.1.1.1
123.123.123.123.123
.123.123.123.123
123.123.123.123.
1.2.3.256
1.2.260.1
1.333.1.1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}