import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\.)((^|\\.)([1-9]?\\d|1\\d\\d|2(5[0-5]|[0-4]\\d))){4}$";
final String string = "115.42.150.37\n"
+ "192.168.0.1\n"
+ "110.234.52.124\n\n"
+ "01.01.01.01\n"
+ "1.1.1.01\n"
+ "123123123213\n"
+ "210.110\n"
+ "255\n"
+ "y.y.y.y\n"
+ "255.0.0.y\n"
+ "666.10.10.20\n"
+ "4444.11.11.11\n"
+ "33.3333.33.3\n"
+ "365.1.1.1\n"
+ "123.123.123.123.123\n"
+ ".123.123.123.123\n"
+ "123.123.123.123.\n"
+ "1.2.3.256\n"
+ "1.2.260.1\n"
+ "1.333.1.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}