package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(O gato ).*?(subiu|caiu).*?( \d+m)`)
var str = `O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}