$re = '/(?=(?:\D*\d\D*){8,14}$)[- \d()+]/m';
$str = 'blabla 01 02 03 04 05 blabla 0102030405 blabla +33102030405 blabla 01-02-03-04-05 blabla 01.02.03.04.05 blabla +33 1 02 03 04 05 blabla (33)102030405';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);