use strict;
my $str = '
את זה הוא תופס יפה
שלום לבא שבת@30שלום לבא שבת@40שלום לבא שבת
את זה אני רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@
את זה אני לא רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@10';
my $regex = qr/(?!@20|@200)(@30)[^(@40)]{1,}(@40)(?!(@10|200)])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}