$re = '/(?!@20|@200)(@30)[^(@40)]{1,}(@40)(?!(@10|200)])/';
$str = '
את זה הוא תופס יפה
שלום לבא שבת@30שלום לבא שבת@40שלום לבא שבת
את זה אני רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@
את זה אני לא רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);