using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$";
string input = @"1.a12_12
111_121s
dfsdf
3412341
1dsfs3_c";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}