package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$`)
var str = `1.a12_12
111_121s
dfsdf
3412341
1dsfs3_c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}