const regex = /^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$', 'gm')
const str = `1.a12_12
111_121s
dfsdf
3412341
1dsfs3_c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}