#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)"
Local $sString = "{SPEAKER} Some text" & @CRLF & _
"{GROUP OF SPEAKERS} Some text"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)