package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)`)
var str = `{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}