// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)").unwrap();
let string = "{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}