import Foundation
let pattern = #"^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)