# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<ssn>(?<!\d{1})\d{3}[\s-]+\d{2}[\s-]+\d{4}(?!\d{1})|(?<!\d{1})\d{9}(?!\d{1}))|(?<creditCard>(?<![0-9]{1})(?:4[0-9]{12}(?:[0-9]{3})?|\d{4}[\s-]+\d{4}[\s-]+\d{4}[\s-]+\d{4}|\d{4}\d{4}\d{4}\d{4}|(?:5[1-5][0-9]{2}|222[1-9]|22[3-9][0-9]|2[3-6][0-9]{2}|27[01][0-9]|2720)[0-9]{12}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}|(?:2131|1800|35\d{3})\d{11})(?![0-9]{1}))"
test_str = ("113-01-1111\n"
"213 81 1111\n"
"1553 01 1111\n"
"153 01 1111\n"
"153 01 11113\n"
"153-01-1111\n"
" 153-01-1111 \n"
"1313 01 11511\n\n"
"153-01-1111\n"
" 153-01-1111 \n"
"\\n113-01-1111 \n"
"\\t113-01-11114\n"
"\\t113-01-1111\\t\n"
"\\t 113-01-1111\\t\n"
"\\t113-01-1111 4\n"
"\\t113-01-11114\n"
"\\t113-01-1111\n\n"
"Robert Aragon 489‑36‑8350 4929‑3813‑3266‑4295\n"
"Ashley Borden 514‑14‑8905 5370‑4638‑8881‑3020\n"
"Thomas Conley 690‑05‑5315 4916‑4811‑5814‑8111")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.