const regex = /^Content\/([A-Z][a-zA-z0-9\_]*\/)*(BP|T|M|MI)\_[A-Z].[a-zA-Z]+\.(uasset|umap)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Content\\\/([A-Z][a-zA-z0-9\\_]*\\\/)*(BP|T|M|MI)\\_[A-Z].[a-zA-Z]+\\.(uasset|umap)', 'gm')
const str = `Content/Ass/Ass/Bdd_01/BP_Asset.uasset`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}