re = /^Content\/([A-Z][a-zA-z0-9\_]*\/)*(BP|T|M|MI)\_[A-Z].[a-zA-Z]+\.(uasset|umap)/m
str = 'Content/Ass/Ass/Bdd_01/BP_Asset.uasset'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end