import Foundation
let pattern = #"звук ([Гг]ав!|[Мм]яу!)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
звук мяу!
звук Мяу!
звук гав!
звук Гав!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Если улышал \0 Скажи в ответ: \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)