$re = '/(?\'year\'\d{4})-(?\'month\'\d{1,2})-(?\'day\'\d{1,2})(.*.mp4)/m';
$str = '2020-7-3; blah.mp4
2022-08-03_blah.mp4
2013-04-03-20-34-08; blah.mp4';
$subst = "$year\($month-$day\).mp4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;