using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^0-9+-]+|([+-])[^0-9]+|([0-9])[^0-9.]+";
string substitution = @"$1$2";
string input = @"37,080 lbs";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}