re = /^[^0-9+-]+|([+-])[^0-9]+|([0-9])[^0-9.]+/m
str = '37,080 lbs'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result