#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([A-ZÄäÖöÜüß.\s-]+?)\s*(\d+(?:[/-]\d+)?(?:[A-Z](?:-[A-Z])?)?)\b"
Local $sString = "Berliner Str. 74" & @CRLF & _
"Hindenburgdamm 27, Hygiene-Institut" & @CRLF & _
"Peschkestr. 5a/Holsteinische Str. 44" & @CRLF & _
"Lankwitzer Str. 13-17a" & @CRLF & _
"Fidicinstr. 15A" & @CRLF & _
"Johanna-Stegen-Strasse 14a-d" & @CRLF & _
"Friedrichshaller Str. 7" & @CRLF & _
"Haudegen Weg 15/17" & @CRLF & _
"Südwestkorso 9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")