using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?!\bper)(?!\bdef).)*";
string input = @"Duo perfecto pertinax ea, falli invidunt atomorum ne vel. Periculis dignissim sea no, his nisl esse suscipiantur te, accumsan similique ad usu. Ea commune percipit quaerendum vel, tritani phaedrum indoctum nec et, cum ea cibo appetere cotidieque. Ex pri illud officiis, usu tota iusto forensibus ei, sint ponderum mediocrem per cu. Cum laudem impetus gloriatur ne. An mea accusata platonem, ei quis integre maiestatis cum.
Nec odio case tacimates in. Pro ex wisi scaevola intellegebat, ea vero iriure comprehensam has. Quis meliore interesset vel in. Eum ea debet omittam. Sit malis atqui ex. Consul definitionem an pri, has alii suscipiantur ei.
Eum eu euismod fabulas detraxit. Aperiam antiopam ei nam, has ea enim facete atomorum. Cu solet eleifend intellegebat mei, autem movet torquatos cu nec. Est ut oblique nostrud principes, ex purto aeterno efficiantur vel. Vis ut pericula voluptatibus, esse iudico ceteros mel ut.
Id fugit admodum mediocrem eam. Vel meis maiorum no, cum possim lucilius recteque an. Duo in natum numquam euismod. Nibh veniam primis has ad, sint movet aperiri no est. Nec ea eius dolore omittam. Te melius legendos vituperata eam, an pro malis persequeris, cu altera expetendis disputando has.
No sea nisl ornatus corpora. Ut ipsum soluta viderer pri, pro ne solum graeci. Vel eu sint accumsan apeirian, ius oratio torquatos at. Vis eu dolore persius insolens, ei qui euismod efficiantur, mel te unum nullam antiopam.
Elitr ridens invidunt his ea, ridens graecis moderatius nec id. At nisl definitiones ius. Nostrud ponderum ne qui, volumus principes quaerendum ex quo. Id per novum explicari. Vel iuvaret salutatus evertitur cu. Pro tale utinam aliquip id.
Cibo timeam inciderint per cu, integre urbanitas ad quo. Veri mollis latine pri ea. Est utamur fabulas at, duo tollit vivendum neglegentur at. Dolorum denique ut mei, ut pro explicari patrioque disputationi. Vis vitae feugiat in. Quo utroque facilis vulputate ad.
Nam lorem principes ea. In elit fierent explicari pro. Congue euismod delicata te qui. At dicam antiopam vituperatoribus has, sit everti dignissim an, nam ne alia eruditi minimum. Invidunt hendrerit eu cum, sed nobis alienum te. Ad usu probo bonorum abhorreant, ad omnesque ponderum senserit eos. At cum voluptua signiferumque.
Cum populo evertitur referrentur id, in alii suavitate voluptatibus cum. Est vidisse perfecto in, eum et sumo sensibus. Ius graece verear ex, in nibh praesent pertinacia mei. Sit at diam sint ubique, at mei velit tacimates. Ei eos natum facete urbanitas. Pri at decore definiebas, mel libris vulputate argumentum an.
Virtute inciderint pro ut. Eum ex vitae laudem. Vix copiosae facilisis et, etiam error ex nam. At duis melius sea. In probo discere lobortis per, id viris primis vix. Etiam impedit pro et, sint mollis fabulas per ne. Falli neglegentur suscipiantur at quo, et vix admodum verterem.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}