#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:https?://)?(?:[\w-]+\.)*nytimes\.com/[\w/.\-#?&=]*\b"
Local $sString = "|url=https://thelede.blogs.nytimes.com/2008/01/15/mona-lisas-identity-solved-for-good/?searchResultPosition=2&mtrref=www.nytimes.com&gwh=9DE4B32CC79812F2537467E9D52707E9&gwt=pay&assetType=REGIWALL}}" & @CRLF & _
"" & @CRLF & _
"|url=https://www.nytimes.com/1987/01/09/opinion/l-couldn-t-mona-lisa-just-stay-a-mystery-361987.html |access-date=2022-07-10" & @CRLF & _
"" & @CRLF & _
"[https://www.nytimes.com/2022/04/25/technology/musk-twitter-sale.html?searchResultPosition=19 Normal external link]" & @CRLF & _
"" & @CRLF & _
"this one might be found someblog.nytimes.com/musk-twitter-sale#maybe?searchResultPosition=17 randomly in text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")