import re
regex = re.compile(r"\b(?:https?://)?(?:[\w-]+\.)*nytimes\.com/[\w/.\-#?&=]*\b", flags=re.MULTILINE)
test_str = ("|url=https://thelede.blogs.nytimes.com/2008/01/15/mona-lisas-identity-solved-for-good/?searchResultPosition=2&mtrref=www.nytimes.com&gwh=9DE4B32CC79812F2537467E9D52707E9&gwt=pay&assetType=REGIWALL}}\n\n"
"|url=https://www.nytimes.com/1987/01/09/opinion/l-couldn-t-mona-lisa-just-stay-a-mystery-361987.html |access-date=2022-07-10\n\n"
"[https://www.nytimes.com/2022/04/25/technology/musk-twitter-sale.html?searchResultPosition=19 Normal external link]\n\n"
"this one might be found someblog.nytimes.com/musk-twitter-sale#maybe?searchResultPosition=17 randomly in text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")