#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+:(\w.*)"
Local $sString = "this string should not match" & @CRLF & _
"" & @CRLF & _
"bob_1:Hi. I'm Bob. I speak русский and this string should match " & @CRLF & _
"" & @CRLF & _
"alice:Hi Bob. I speak 한국어 and this string should also match" & @CRLF & _
"" & @CRLF & _
"http://example.com - would prefer to not match URLs" & @CRLF & _
"" & @CRLF & _
"This string:should not match because no spaces or capital letters are allowed left of the colon"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")