import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][a-z0-9_-]*( +[A-Z][a-z0-9_-]*)*$";
final String string = "TesT Name\n"
+ "TEST NAME\n"
+ "Test Name\n"
+ "Test-here Name-there\n"
+ "Test-here Name-------there";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}