re = /^[A-Z][a-z0-9_-]*( +[A-Z][a-z0-9_-]*)*$/m
str = 'TesT Name
TEST NAME
Test Name
Test-here Name-there
Test-here Name-------there'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end