#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*[^-])\s(\d.*)$"
Local $sString = "Friedr 5 ichstr 4" & @CRLF & _
"Friedrichstr. 44" & @CRLF & _
"Friedrichstr. 4a" & @CRLF & _
"Friedrichstr. 4A" & @CRLF & _
"Friedrichstr. 44a" & @CRLF & _
"Friedrichstr. 423B" & @CRLF & _
"Friedrichstr. 4a-5" & @CRLF & _
"Friedrichstr. 4-5A" & @CRLF & _
"Friedrichstr. 4 - 5" & @CRLF & _
"Friedrichstr. 4A - 34B" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")