const regex = /^(.*[^-])\s(\d.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*[^-])\\s(\\d.*)$', 'gm')
const str = `Friedr 5 ichstr 4
Friedrichstr. 44
Friedrichstr. 4a
Friedrichstr. 4A
Friedrichstr. 44a
Friedrichstr. 423B
Friedrichstr. 4a-5
Friedrichstr. 4-5A
Friedrichstr. 4 - 5
Friedrichstr. 4A - 34B
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}