# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*[^-])\s(\d.*)$"
test_str = ("Friedr 5 ichstr 4\n"
"Friedrichstr. 44\n"
"Friedrichstr. 4a\n"
"Friedrichstr. 4A\n"
"Friedrichstr. 44a\n"
"Friedrichstr. 423B\n"
"Friedrichstr. 4a-5\n"
"Friedrichstr. 4-5A\n"
"Friedrichstr. 4 - 5\n"
"Friedrichstr. 4A - 34B\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.