#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(-?\d+)([a-z]*)|(-)?([a-z]+)$"
Local $sString = "-24mn" & @CRLF & _
"-100BC" & @CRLF & _
"100BC" & @CRLF & _
"100" & @CRLF & _
"BC" & @CRLF & _
"-bC" & @CRLF & _
"-100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")