package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(-?\d+)([a-z]*)|(-)?([a-z]+)$`)
var str = `-24mn
-100BC
100BC
100
BC
-bC
-100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}