import re
regex = re.compile(r"\b0+\B", flags=re.MULTILINE)
test_str = ("092.01.001.220\n"
"192.16.092.000\n"
"02.1.001.01\n"
"010.064.214.210 \n"
"010.064.000.150 \n"
"010.000064.017.001 \n"
"127.00000.0.001 \n"
"10.0.00.000 \n"
"010.064.105.201")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)