package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n(\n+)`)
var str = `A
B
C
D`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}