use strict;
my $str = 'A
B
C
D';
my $regex = qr/\n(\n+)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";