$re = '/^(?:\d+|\d{1,3}([ _.,])\d{3}(?:\1\d{3})*)$/m';
$str = '1
12
123
123.456.789.884
12.55
12.345
2,234,647
2,234_754
2 234 723
123456
1
12
123
1234
12345
123456
1234567
123.456789
12.123.
1234567890,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);