import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "node\\.([[:alnum:]]*?)\\.";
final String string = "// Print `Hello, world!` every one second.\n"
+ "if (Global.currentFrame % Global.targetFPS == 0) {\n"
+ " print(node.sensorlink.encoder1Position) //.encoder1Position);\n"
+ " // print(node.sensorlink.encoder1Position) //.encoder1Position);\n"
+ " \"print(node.sensorlink.encoder1Position) //.encoder1Position);\"\n"
+ " 'print(node.sensorlink.encoder1Position) //.encoder1Position);'\n"
+ "}\n\n"
+ "// Node(\"sensorlink\").encoder2PositionRelative\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}