# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)$\n.*,\s(.*)$/$1 - $2/gms;t' <<< "Awakening
En-Core, Malyarovsky Maxim, Nikita"