package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^(.*)$\n.*,\s(.*)$`)
var str = `Awakening
En-Core, Malyarovsky Maxim, Nikita`
var substitution = "$1 - $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}