use strict;
my $str = 'Awakening
En-Core, Malyarovsky Maxim, Nikita';
my $regex = qr/^(.*)$\n.*,\s(.*)$/msp;
my $subst = '$1 - $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";